FC2ブログ

[VMware]トラブルシューティング

VMware Toolが再インストールできない

ホスト: x1、Win 10
ゲスト: CentOS 7
VMwareバージョン: VMware Workstation 15 Player (15.0.1)

ゲストマシン起動時に、上のメニューバーの「Player」ボタンから
 > 管理 > VMware Toolsの再インストール
とやっても、

ゲストOSがCD-ROMドアをロックし、CD-ROMを使用している可能性があります。このためゲストはメディアの変更を認識できません。可能な場合は切断する前に、CD-ROMをゲスト内部から取り出してください。
このまま切断してロックを無視しますか。

となる。
これで「はい」を押して進んでも、成功した時のように、CDドライブフォルダが開いて、
VMwareTools-10.3.2-9925305.tar.gz
のようなファイルが見えない。
CDドライブはEmptyになってる。

これを解決するためには以下。

左上のPlayer(P) >  管理 > 仮想マシン設定 > CD/DVD(IDE)
 > デバイスのステータス
 > 「接続済み」、「起動時に接続」の両方からチェックを外す。

これで一度ゲストOSを停止してから再起動する。そして
左上の「Player」ボタン > 管理 > VMware Toolsの再インストール
とすると、今度はCDドライブのフォルダが自動的に開いた。
あとはいつも通り、
VMwareTools-10.3.2-9925305.tar.gz
をどこかにコピーして、展開して、中にあるplスクリプトを
./vmware-install.pl
と実行する。流れに任せて、基本はすべてEnterを押してるとインストールは完了する。
あとはゲストOSを再起動したら、/mnt/hgfs/の中に、共有フォルダが見えるようになってた。


ゲストWindows(Server Essential 2016)で共有フォルダ見えない

VMware > 対象のゲスト > 右クリック > 設定 > オプション > 共有フォルダ
 > Windowsゲストのネットワークドライブとしてマップする、にチェック。

こうすれば、ネットワークドライブとして見える、とあったがやはり見えない。



ホストとゲスト間でクリップボードが共有できない(確認前)

ホスト側のテキストをコピーしても、ゲストOS上でペーストが出来ない。
解析方法は以下らしい。

.vmxファイルに以下の設定を追記。
isolation.tools.copy.disable = false
isolation.tools.paste.disable = false




USBメモリ内容が読めない

FATフォーマットのUSBメモリをホストからVMwareゲストへ接続。
するとこんなメッセージが出る。

[ 3702.69xxxx] sd 33:0:0:0: [sdb] No Caching mode page found
[ 3702.69xxxx] sd 33:0:0:0: [sdb] Assuming drive cache: write through



/dev/sdb1として認識したので、mountして中身を見てみたが、コピーしたはずのデータが見れない。
・・・

すみません、単純な話でした。以下の通りオプションつけたらデータ見れました。
# mount /dev/sdb1 /mnt/hoge > 誤
# mount -t vfat /dev/sdb1 /mnt/hoge > 正
スポンサーサイト

[VMware]ESXiインストール

ホスト: P8H67-M EVO
バージョン: ESXi 6.5.0a
スイッチ: GS116E-200JPS

インストールは出来たけど、
Test Management Networkでpingが最寄りのスイッチにも通らない。なぜ?

スイッチとは100Mでリンクアップしてる。
根拠は、
スイッチの管理画面では100Mでリンクアップとなってる。またスイッチポートはAuto Neg設定になってた。
ホストのオンボードLANのLEDはオレンジになってる。

通信出来ないケースとしては以下があるが。。

スイッチ=Auto Neg
ホスト=100M全二重固定



この場合、スイッチから見たら、ホスト側がAuto Negしてないので、Auto Negプロセスに失敗する。
失敗すると、Auto Negしてたスイッチは100M半二重に設定するのがルール。
なので、ホスト側の100M全二重と一致せずに、通信出来ない。

[VMware]NAT時GATEWAY=192.168.142.2

VMwareでゲストOSのネットワーク設定をNATにしている時、192.168.142.xxxというIPがDHCPで
割り振られていた。
毎回起動のたびに変わるので、固定IPにしたくて、NIC設定ファイルでdhcpからstaticにして、
GATEWAY=192.168.142.1とした。

するとネットに繋がらない。

http://www.nslabs.jp/linux-nat-on-vmware.rhtml


ちょうどこの記事を発見して、内容見たら、GATEWAYは192.168.142.2だったいう話。

VMware上のゲストOS(CentOS6.7)でDHCP設定してる時に以下コマンドでGATEWAYを確認する。
-rオプション付けないと意図しない情報が大量に表示されてしまう。

# netstat -r


結果、以下の通り、GATEWAYは、192.168.142.2であるようだ。

default 192.168.142.2

[VMware]起動しない(CentOS)

パワーオン中にエラーが発生しました: 操作がユーザーによって中断されました。



さっきはPC再起動で起動出来た。

http://yaplog.jp/ceres_2323/archive/46
ここら辺で見ると、
  コントロールパネル > 管理ツール > サービス > VMware Authorization Service を開始してない
事が原因とあるが、サービス開始してた。

どうにも原因不明なので、幸いにも先程同メッセージで起動せずにPC再起動して復旧出来た際に
バックアップ取っておいたので、それを使って起動出来た。あぶなかった。

[VMware]Ubuntu15.04_amd64へVMware Toolsインストール

これまでCentOS等では、仮想マシン起動後、左上のPlayer
 > 管理 > VMware Toolsのインストール
と選択すれば、その後、/media/xxxなどとたどると、マウントされたドライブ上に
VMware Toolsxxx.targzファイルが発見出来た。

しかしUbuntuでやったら、そもそも「VMware Toolsのインストール」がグレーで選択出来ない。
なぜ?
rootになっても変わらず。


しばらくopenriscのツール環境作りを進めてたら、グレーでなくなって選択出来るようになってた。
選択後、/media/bob/VMware Tools/xxxx.tar.gz でインストールデータにアクセス出来る。
カレンダー
06 | 2019/07 | 08
- 1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31 - - -
累積訪問者
現在の訪問者
現在の閲覧者数:
最新記事
最新トラックバック
最新コメント
月別アーカイブ
カテゴリ
プロフィール

bobgosso

Author:bobgosso
FPGAのブログへようこそ!

検索フォーム
RSSリンクの表示
リンク
ブロとも申請フォーム

この人とブロともになる

QRコード
QRコード