FC2ブログ

[Ubuntu]トラブルシューティング

apt update実行時のE: Sub-process returned an error code

Ubuntu 16.04 LTS
OSインストール直後、以下実行するとエラー。

$ sudo apt update
...
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh > /dev/null; fi'
E: Sub-process returned an error code



https://sekisuiseien.com/computer/10530/

こちらを参考にさせて頂き、以下を実行

# cd /tmp
# mkdir asfix
# cd asfix
# wget https://launchpad.net/ubuntu/+archive/primary/+files/appstream_0.9.4-1ubuntu1_amd64.deb
# wget https://launchpad.net/ubuntu/+archive/primary/+files/libappstream3_0.9.4-1ubuntu1_amd64.deb
# sudo dpkg -i *.deb



再度実行してみると成功した。

# apt update

アップグレードできるパッケージが678個あります。xxxx





[Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x52 (or later)

ホスト: h170
OS : Ubuntu 18.04 desktop amd64

インストールしようと、このDVDでブートすると、このメッセージが出た。
このメッセージの後に、次のようなメッセージ。

[ 23.83384xx] print_req_error: I/O error, dev sr0, sector 3652000
[ 23.83389xx] Buffer I/O error on dev sr0, logical block 456510, async page read
[ 33.xxxxxxx] print_req_error: I/O error, dev sr0, sector 3652072
[ 33.xxxxxxx] Buffer I/O error on dev sr0, logical block 456509, async page read



Ubuntu 16.04と画面に出て止まる。 その後インストール始まった

ホスト: h170
OS : Ubuntu 16.04



パーティション設定でProblem

ホスト: h170
OS : Ubuntu 16.04

HDDへ自分でパーティション設定をする、と進んで、Swapに16GB、/bootに200MB、残りを/へ設定し、進むと以下メッセージ。

Go back to the menu and correct this problem?
The partition table format in use on your disks normally requires you to create a separate partition for boot loader code.
This partition should be marked for use as a "Reserved BIOS boot area" and should be at least 1 MB in size.
Note that this is not the same as a partition mounted on /boot.
If you do not go back to the partitioning menu and correct this error, boot loader installation may fail later, although it may still be possible to install the boot loader to a partition.

調べてみると、BIOS予約済エリアが無い事が原因らしい。

そこでパーティション設定に戻り、あらたにBIOS予約領域を35MBで作った。どこかのブログに35MB以上でうまくいくと記載。
すると、エラーが出ずに、次のLocation設定へと進めた。



OSインストール後の再起動で止まる

ホスト: h170
OS : Ubuntu 16.04

OSインストールは成功して、再起動しろ、と出たので、そのまま再起動ボタンを押して、
その後、DVDドライブが開いたので、インストーラDVDを抜いて進めたら、以下メッセージで止まる。

Ubuntu 16.04
A start job is running for Ubuntu 1... installer (1min 40s / no limit)

電源ボタン長押しで強制停止させて、再度電源ONしてみると、正常に起動したようだ。なぜ再起動で止まったか原因不明。
しかし、ログインしていじってみると、マウスやアプリ起動など、いずれの動きも遅い。
例えば端末を起動すると、すごくゆっくりに次第にウィンドウが表示されていく様子が見れる。何かおかしい。

# sudo apt update
更新したら改善するかな?と思ってやってみると、以下エラーで止まった。

7ffed86xxxxx - 7ffed86xxxx r - xp 0000 00:00 0 [vdso]
fffffffffff600000-ffffffff601000 r-xp 00000 00:00 0 [vsyscall]
Aborted (core dumped)
パッケージリストを読み込んでいます... 完了
E: problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh > /dev/null; fi'
E: Sub-process returned an error code


# sudo apt dist-upgrade
こちらも試してみる。
無事、「完了」となったが、まだ反応は遅いまま。
再起動したら、反応が正常になった。グラフィックとかのドライバが入ってなかったって事かな?
ちなみに、この後、
# sudo apt update
とやったら、さっきはエラーになったのが、今度は「全て最新」と出て、正常に完了した。



apt-getでFailed to fetchエラー(Ubuntu17.10)

# apt-get install -y ubuntu-desktop
をやるとこんなエラー。(詳しくはメモってない。IPも91から始まるのは見たが、以下か不明)
E: Failed to fetch http://xxxxx [IP: 91.189.88.173 80]

# ping 8.8.8.8
# ping www.google.co.jp
はいずれもpingが通る。名前解決は問題無い様子。

https://qiita.com/miriwo/items/bc2c0f18ee7d6f337ed0
ここを見て、以下を試す。
# rm -rf /var/lib/apt/lists/*

削除してから再度試すが、今度は以下エラー。
# apt-get install -y ubuntu-desktop

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ubuntu-desktop



# apt update
を試すと、そもそも以下エラーが根本原因に見える。

Err:6 http://security.ubuntu.com/ubuntu artful-security Release
404 Not Found [IP: 91.189.88.174 80]



これを調べると以下に解決策がありそう。
https://qiita.com/ytyng/items/76784390a538bbb5117e

上記のリンク先
https://smyl.es/how-to-fix-ubuntudebian-apt-get-404-not-found-package-repository-errors-saucy-raring-quantal-oneiric-natty/

要約すると、
「archive.ubuntu.comとsecurity.ubuntu.comは、現在old-releases.ubuntu.comになってるから、/etc/apt/sources.listを変更しろ」
という事らしい。

# vi /etc/apt/sources.list
viエディタで開いたら、以下置換コマンドで一括置換。

:%s/us.archive.ubuntu.com/old-releases.ubuntu.com/
:%s/us.security.ubuntu.com/old-releases.ubuntu.com/


us.とかjp.とかは削除する。

これでapt updateでレポジトリサーバにアクセス出来るようになった様子。
ただし、まだ最後に何やらエラー出るな。。。。
そもそも、Ubuntu 18で日本語キーボードレイアウトに設定できないため、Ubuntu17を使ってるが、
古いUbuntuバージョンには、今回のような注意点があるようだ。

# apt install -y vim-gnome
は正常にインストール出来た。
# apt install -y ubuntu-desktop
は以下のエラーが出た。


Errors were encountered while processing:
network-manager-config-connectivity-ubuntu
E: Sub-process /usr/bin/dpkg returned an error code (1)

スポンサーサイト



カレンダー
05 | 2018/06 | 07
- - - - - 1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
累積訪問者
現在の訪問者
現在の閲覧者数:
最新記事
最新トラックバック
最新コメント
月別アーカイブ
カテゴリ
プロフィール

bobgosso

Author:bobgosso
FPGAのブログへようこそ!

検索フォーム
RSSリンクの表示
リンク
ブロとも申請フォーム

この人とブロともになる

QRコード
QRコード