FC2ブログ

[NEEK][Linux]組み込みLinuxまでの手順(5)(UbuntuバージョンUP)

http://www.akiron.com/FPGA/nios2linuxinstall.pdf
この資料見ると、Ubuntuの確認バージョンはv9以上とある。

http://www.ubuntulinux.jp/products/JA-Localized/vmware
ここで配布している8.04を使用しているのでバージョンUPする。

http://aquapple.jugem.jp/?eid=1266
ここに従い進める。

■8.04から8.10へUP
 ・デスクトップ画面 > システム > システム管理 > アップデート・マネージャ > 全てUpdateしておく。

 ・完了したら、画面に「新しいディストリビューション10.04.3LTSにアップグレードできます」と出た。
  「アップグレード」をクリック。(途中出るMSGに答えて先に進む)

 ・アップグレード終わると再起動されて、ログイン。

sudo apt-get update
sudo apt-get install git-core git-gui make gcc ncurses-dev bison flex gawk gettext ccache zliblg-dev libxll-dev texinfo liblzo2-dev pax-utils uboot-mkimage corkscrew
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
git-core はすでに最新バージョンです。
git-gui はすでに最新バージョンです。
make はすでに最新バージョンです。
gcc はすでに最新バージョンです。
注意、ncurses-dev の代わりに libncurses5-dev を選択します
libncurses5-dev はすでに最新バージョンです。
bison はすでに最新バージョンです。
flex はすでに最新バージョンです。
gawk はすでに最新バージョンです。
gettext はすでに最新バージョンです。
ccache はすでに最新バージョンです。
E: パッケージ zliblg-dev が見つかりません



  ・zliblg-devが見つからないと言われた。インストール方法が分からない。

  ・試しに、zliblg-devを指定せずにapt-get installとすると、今度は
E: パッケージ libxll-dev が見つかりません

   と出る。これも除外すると成功する。
   もしかして、Ubuntu 10にUpgradeする時のMSGで「サポートしてないPKGを削除しますか?」でYESしたからかな?

  ・zliblg-devの問題が解決しないけど、ツールチェインビルドしてみると、これまで同様のエラー。
スポンサーサイト



コメントの投稿

非公開コメント

カレンダー
07 | 2021/08 | 09
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 - - - -
累積訪問者
現在の訪問者
現在の閲覧者数:
最新記事
最新トラックバック
最新コメント
月別アーカイブ
カテゴリ
プロフィール

bobgosso

Author:bobgosso
FPGAのブログへようこそ!

検索フォーム
RSSリンクの表示
リンク
ブロとも申請フォーム

この人とブロともになる

QRコード
QRコード